Results 1 to 6 of 6
  1. #1
    Normal User
    Join Date
    Sep 2008
    Location
    London, England
    Posts
    130

    Default Help: Could not establish login server connection:timeout(EU1)

    I accidently installed the US client to test the NA servers while the EU server was down for patching and now even after downloading the EU client and installing it I still get this issue . I have an active sub and any help would be appreciated especially since the server will be back up shortly

  2. #2
    Normal User
    Join Date
    Sep 2008
    Location
    London, England
    Posts
    130

    Default

    bump any help will help

  3. #3
    Normal User US1 Player
    Join Date
    Dec 2008
    Posts
    81

    Default

    The EU and NA clients are 2 different games what server is your account for?
    The EU might still be down for the expac.

  4. #4
    Normal User
    Join Date
    Sep 2008
    Location
    London, England
    Posts
    130

    Default

    My account is for the EU server but I've noticed that other EU players can access lobby and already downloaded the patch

  5. #5
    Moderator
    Join Date
    Mar 2009
    Posts
    2,274

    Default

    I guess you have already tried restarting your computer?

  6. #6
    Normal User
    Join Date
    Sep 2008
    Location
    London, England
    Posts
    130

    Default

    Quote Originally Posted by Teucrus View Post
    I guess you have already tried restarting your computer?
    I love you teucrus, I hppe life will bring you many beautiful women and riches
    It worked! I feel so dumb now :P

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •